Slackware Security Advisories (sigurnosne nadogradnje)

Novosti u vezi Slackware Linuxa

Moderator: Urednik

Locked

Administrator
Administrator
offline
User avatar

Posts: 2750
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 16 Mar 2019, 00:18


08.03.2019.

Sveži ntp paketi za Slackware 14.0, 14.1, 14.2. i -current:

Code: Select all

patches/packages/ntp-4.2.8p13-i586-1_slack14.2.txz:  Upgraded.
  This release fixes a bug that allows an attacker with access to an explicitly
  trusted source to send a crafted malicious mode 6 (ntpq) packet that can
  trigger a NULL pointer dereference, crashing ntpd.
  It also provides 17 other bugfixes and 1 other improvement.
  For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8936
  (* Security fix *)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2750
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 24 Mar 2019, 01:06


18.03.2019.

Sveži libssh2 paketi za Slackware 14.2 i -current:

Code: Select all

patches/packages/libssh2-1.8.1-i586-1_slack14.2.txz:  Upgraded.
  Fixed several security issues.
  For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3855
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3856
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3857
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3858
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3859
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3860
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3861
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3862
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3863
  (* Security fix *)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2750
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 24 Mar 2019, 01:08


22.03.2019.

Sveži mozilla-firefox paketi za Slackware 14.2 i -current:

Code: Select all

patches/packages/mozilla-firefox-60.6.1esr-i686-1_slack14.2.txz:  Upgraded.
  This release contains security fixes and improvements. The patched flaws
  are considered critical, and could be used to run attacker code and install
  software, requiring no user interaction beyond normal browsing.
  For more information, see:
    https://www.mozilla.org/security/known-vulnerabilities/firefoxESR.html
    https://www.mozilla.org/en-US/security/advisories/mfsa2019-10/
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9810i
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9813
  (* Security fix *)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2750
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 01 Apr 2019, 19:55


25.03.2019.

Sveži mozilla-thunderbird paketi za Slackware 14.2 i -current:

Code: Select all

patches/packages/mozilla-thunderbird-60.6.1-i686-1_slack14.2.txz:  Upgraded.
  This release contains security fixes and improvements.
  For more information, see:
    https://www.mozilla.org/en-US/thunderbird/60.6.1/releasenotes/
    https://www.mozilla.org/security/known-vulnerabilities/thunderbird.html
  (* Security fix *)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2750
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 01 Apr 2019, 19:56


27.03.2019.

Sveži gnutls paketi za Slackware 14.2 i -current:

Code: Select all

patches/packages/gnutls-3.6.7-i586-1_slack14.2.txz:  Upgraded.
  Fixes security issues:
  libgnutls, gnutls tools: Every gnutls_free() will automatically set
  the free'd pointer to NULL. This prevents possible use-after-free and
  double free issues. Use-after-free will be turned into NULL dereference.
  The counter-measure does not extend to applications using gnutls_free().
  libgnutls: Fixed a memory corruption (double free) vulnerability in the
  certificate verification API. Reported by Tavis Ormandy; addressed with
  the change above. [GNUTLS-SA-2019-03-27, #694]
  libgnutls: Fixed an invalid pointer access via malformed TLS1.3 async
  messages; Found using tlsfuzzer. [GNUTLS-SA-2019-03-27, #704]
  libgnutls: enforce key usage limitations on certificates more actively.
  Previously we would enforce it for TLS1.2 protocol, now we enforce it
  even when TLS1.3 is negotiated, or on client certificates as well. When
  an inappropriate for TLS1.3 certificate is seen on the credentials
  structure GnuTLS will disable TLS1.3 support for that session (#690).
  libgnutls: enforce the equality of the two signature parameters fields
  in a certificate. We were already enforcing the signature algorithm,
  but there was a bug in parameter checking code.
  (* Security fix *)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”


Locked

Who is online

Users browsing this forum: No registered users and 2 guests