64-bitni Slack vs 32-bitni Slack sa PAE

Ovaj deo je namenjen diskusiji koja nije vezana ni za jednu prethodnu kategoriju, a tiče se Slackware linuxa

Moderator: Urednik


Administrator
Administrator
offline
User avatar

Posts: 2681
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 17 Aug 2015, 19:38


Hvala Bocke za opširan odgovor samo što ne želim da imam multilib već čisto 64bit okruženje. No vidim da je još uvek rano za full 64bit okruženje. Sistem mi je već podešen, valjda dodavanje multiliba neće imati neke neželjene posledice :)

A Eagle je CAD je program za izradu PCB-a. Freeware ima svoja ograničenja ali je sasvim dovoljno za kućnu radinost.
http://www.cadsoft.de/" onclick="window.open(this.href);return false;
https://en.wikipedia.org/wiki/EAGLE_%28program%29" onclick="window.open(this.href);return false;

Za teamviewer sam zaboravio da ide sa wine :)
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 4073
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 19 Aug 2015, 14:26


Mislim da multilib nema mnogo problema. Generalno radi sasvim fino. Ali ako već pitaš za probleme...

Može postojati problem sa nekim SlackBuildovima sa SlackBuilds.org. Konfiguraciona podešavanja alatki za izgradnju (autotools, qmake, cmake) nekih programa traže biblioteke sistema u /usr/lib umesto u /usr/lib64 pa se pojavi greška o pogrešnoj arhitekturi. Ali ovo se ne dešava kod svih paketa.

Lek? Ili izmeniti SlackBuild na način koji će naterati ove alatke da koriste /usr/lib64 ili privremeno premestiti /usr/lib (recimo u /usr/lib32), a zatim vratiti na prethodnu lokaciju nakon kompilacije.

Drugi problem na koji sam nailazio je problem sa kockicama umesto fontova u 32-bitnim gtk2 aplikacijama. To nije teško rešiti.

Slakov rc.M sadrži:

Code: Select all

# These GTK+/pango files need to be kept up to date for
# proper input method, pixbuf loaders, and font support.
if [ -x /usr/bin/update-gtk-immodules ]; then
  /usr/bin/update-gtk-immodules --verbose
fi
if [ -x /usr/bin/update-gdk-pixbuf-loaders ]; then
  /usr/bin/update-gdk-pixbuf-loaders --verbose
fi
if [ -x /usr/bin/update-pango-querymodules ]; then
  /usr/bin/update-pango-querymodules --verbose
fi
Potrebno je dodati i (ovo takođe može u /etc/rc.d/rc.local):

Code: Select all

if [ -x /usr/bin/update-gdk-pixbuf-loaders-32 ]; then
  /usr/bin/update-gdk-pixbuf-loaders-32 --verbose
fi
if [ -x /usr/bin/update-pango-querymodules-32 ]; then
  /usr/bin/update-pango-querymodules-32 --verbose
fi



Administrator
Administrator
offline
User avatar

Posts: 2681
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 06 Sep 2015, 12:11


Od sinoć koristim multilib, osim što skype nema zvuk, drugih problema nisam našao (još uvek). Čistokrvni 64-bitni sistem mi nije odgovarao usled nedostataka nekih programa kojih ima samo u 32-bitnom izdanju.

Napisaću kasnije i neku reč o ukupnom utisku.

P.S. "kasnije" = nekoliko nedelja
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 4073
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 06 Sep 2015, 13:39


Skype u novim verzijama zahteva pulseaudio. Ali postoji i zaobilaznica: korišćenje alatke koja se zove apulse.



Stalni član
Stalni član
offline

Posts: 45
Joined: 04 Aug 2015, 11:06
Location: Beograd

Post Napisano: 06 Sep 2015, 16:39


da pitam nešto vezano za ovo ,a da ne otvaram novu temu .
da li je moguće sa 32bitne verzije preći na 64 odnosno dodati multilib ili multi arch.
obrnut postupak mi je jasan, ali za ovaj ne znam da li je moguć ili je jednostavno bolje instalirati 64 bitnu, pa
dodati multlib za 32 bitnu verziju.



Administrator
Administrator
offline
User avatar

Posts: 2681
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 06 Sep 2015, 17:22


@bocke, hvala, znam za pulseaudio zavisnost i apulse, u trenutku kad sam pisao post bio je instaliran pulseaudio ali moguće da nije dodata grupa za korisnika da koristi pulseaudio. No, kako mi je trebalo hitno rešenje, instalirao sam apulse a obrisao pulseaudio i to radi.

Hteo sam da zaronim dublje jer ima i neka konverzija paketa da se odradi (json-c, speex i pulseaudio). Da mi nije trebao skype brzo, našao bi rešenje i bez apulse, no...

Ne znam za 14.1 ali na -currentu se ne kompajlira pavucontrol (iz SBo). Nisam još zagledao zašto.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 4073
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 07 Sep 2015, 23:24


@stereo: Nisam ulazio dublje. :) Poslednji put kad sam probao, nisi mogao u isto vreme da koristiš i Pulseaudio i aplikacije koje koriste Alsu direktno. To me je smorilo i nisam se više igrao s time. Doduše, mislim da sam naleteo na neki alsa plugin koji to rešava, ali nisam imao volje da se igram s time.
duxim wrote:da pitam nešto vezano za ovo ,a da ne otvaram novu temu .
da li je moguće sa 32bitne verzije preći na 64 odnosno dodati multilib ili multi arch.
obrnut postupak mi je jasan, ali za ovaj ne znam da li je moguć ili je jednostavno bolje instalirati 64 bitnu, pa
dodati multlib za 32 bitnu verziju.
Ne. Tj. možda da, ali ćeš najverovatnije dobiti polu-funkcionaln sistem sa dosta problema. Obično je preporuka instalacija 64-bitne verzije. Kad imaš odvojenu root poziciju to je mačji kašalj.



Stalni član
Stalni član
offline

Posts: 45
Joined: 04 Aug 2015, 11:06
Location: Beograd

Post Napisano: 08 Sep 2015, 08:57


@ bocke
hvala na odgovoru. pretpostavio sam da je tako. za par dana ću da instaliram 64bitnu verziju
Slacware pa ću da vidim razliku. ;)


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest