[REŠENO] Nakon jučerašnje nadogradnje currenta pukao X

Ukoliko imate problema sa instalacijom ili korišćenjem nekog programa, ovo je pravo mesto za vaše pitanje.

Moderators: Slackmuz, Urednik


Poznata ličnost
Poznata ličnost
offline

Posts: 99
Joined: 12 Jan 2012, 10:22
Location: Novi Sad

Post Napisano: 12 Sep 2013, 13:15


Samo stavi neki drugi server za nadogradnju, npr. slackware.at, ja njega koristim i pokreni:

Code: Select all

slackpkg --update
slackpkg --upgrade-all



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 13:19


Reinstalirao sam Xfce, nema promene... na irc kanalu se ništa ne spominje oko ovog problema...

Nadogradnju uvek radim sa američkog servera.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 13:39


Još sam imao i neke novije pakete i njih sam vratio na verziju koja je na serveru. Reinstalirao sam drajver za amd, pokrenuo opet xwmconfig, izabrao okruženje i sve što se inače radi. Reinstalirao sam ceo xfce i opet ništa.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 13:40


Da ne zaboravim, uradio sam i reinstalaciju mesa drajvera. Ista stvar i bez vlasničkih drajvera i sa njima.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 4085
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 12 Sep 2013, 13:49


zero wrote:Menjaj taj ETF za nešto drugo. Sad sam uporedio ChangeLog-e za Current na Slackware-ovom sajtu i na ETF-u.
Primer razlike:

Code: Select all

xfce4-session-4.10.1-i486-3.txz - Sep 9 - slackware.com 
xfce4-session-4.10.0-i486-1.txz - 20-Jul-2012 - ETF
Uh... Znao sam da su pozadi, ali ne i da toliko kasne. Trebalo bi ih kontaktirati, ali da ne offtopikujemo sad.

Elem, stavljam "current" u naslov teme.



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 13:57


Sad sam nešto gledao, ja nemam libxcb-util paket uopšte. Nema ga kroz slackpkg, slacky.eu a ni sbopkg. Probaću da ga nađem kod aliena ili slično pa javljam. Meni su svi paketi lepo radili do ove nadogradnje...

P.S. imam xcb-util a valjda to nije isto??

EDIT: moja greška, imam libxcb-util
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 14:14


Novi log, nakon svega, izgleda ovako:

Code: Select all

xauth:  file /home/zeljko/.serverauth.4202 does not exist


X.Org X Server 1.13.4
Release Date: 2013-04-17
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.1 Slackware Linux Project
Current Operating System: Linux stereo 3.10.9-smp #2 SMP Wed Aug 21 15:35:02 CDT 2013 i686
Kernel command line: auto BOOT_IMAGE=Slackware ro root=811 vt.default_utf8=1
Build Date: 18 April 2013  01:51:03AM
 
Current version of pixman: 0.30.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 12 15:12:23 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
Loading extension ATIFGLRXDRI
Loading extension FGLRXEXTENSION
Loading extension GLESX
Loading extension AMDXVOPL
Loading extension AMDXVBA
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
(EE) module ABI major version (19) doesn't match the server's version (18)
/usr/bin/startxfce4: X server already running on display :0
xfce4-panel-Message: Plugin "mixer-2" was not found and has been removed from the configuration
/usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin: error while loading shared libraries: libxcb-util.so.0: cannot open shared object file: No such file or directory
xfce4-panel-Message: Plugin xkb-plugin-5 has been automatically restarted after crash.
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
/usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin: error while loading shared libraries: libxcb-util.so.0: cannot open shared object file: No such file or directory

(xfdesktop:4253): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed

(xfdesktop:4253): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed
xfce4-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
** Message: PID 4262 (we are 4262) sent signal 15, shutting down...
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

(xfdesktop:4253): libxfce4ui-WARNING **: ICE I/O Error

(xfdesktop:4253): libxfce4ui-WARNING **: Disconnected from session manager.
xinit: connection to X server lost

waiting for X server to shut down xscreensaver: 15:12:26: SIGHUP received: restarting...
xscreensaver: 15:12:26: initial effective uid/gid was zeljko/shadow (1000/43)
xscreensaver: 15:12:26: running as zeljko/users (1000/100)


(xfsettingsd:4254): libxfce4ui-WARNING **: ICE I/O Error

(xfsettingsd:4254): libxfce4ui-WARNING **: Disconnected from session manager.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
xfsettingsd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xscreensaver: 15:12:26: Can't open display: :0.0
xscreensaver: 15:12:26: initial effective uid/gid was zeljko/shadow (1000/43)
xscreensaver: 15:12:26: running as zeljko/users (1000/100)

xscreensaver: 15:12:26: Errors at startup are usually authorization problems.
              But you're not logging in as root (good!) so something
              else must be wrong.  Did you read the manual and the FAQ?

              http://www.jwz.org/xscreensaver/faq.html
              http://www.jwz.org/xscreensaver/man.html

Server terminated successfully (0). Closing log file.

Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Poznata ličnost
Poznata ličnost
offline

Posts: 99
Joined: 12 Jan 2012, 10:22
Location: Novi Sad

Post Napisano: 12 Sep 2013, 14:21


Moraš ponovo izgraditi paket xfce4-xkb-plugin sa SBo.



Administrator
Administrator
offline
User avatar

Posts: 2768
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 12 Sep 2013, 14:32


Odradio sam, xkb-plugin radi ok sad ali i dalje sam blokiran, miš i tastatura ne reaguju nikako. Imam još noviji log (čuvam i one stare).
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Poznata ličnost
Poznata ličnost
offline

Posts: 99
Joined: 12 Jan 2012, 10:22
Location: Novi Sad

Post Napisano: 12 Sep 2013, 14:38


Sad videh da imaš stariji xorg. Ovako treba da izgleda nakon punog ažuriranja (kernel verziju zanemari):

Code: Select all

X.Org X Server 1.14.2
Release Date: 2013-06-25
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.1 Slackware Linux Project
Current Operating System: Linux slack 3.9.7-smp #2 SMP Sat Jun 22 03:28:23 CDT 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-huge-smp-3.9.7-smp root=/dev/sdb1 ro ipv6.disable=1
Build Date: 05 September 2013  10:46:09PM
Još jednom apelujem da promeniš server za nadogradnju. :grin:
Edit:
I odradi:

Code: Select all

# slackpkg install xcb-util-cursor
Last edited by zero on 12 Sep 2013, 14:46, edited 2 times in total.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest