Viber instalacija na Slackware 14.1 64

Ukoliko imate problema sa instalacijom ili korišćenjem nekog programa, ovo je pravo mesto za vaše pitanje.

Moderators: Slackmuz, Urednik

Post Reply

Stalni član
Stalni član
offline

Posts: 45
Joined: 04 Aug 2015, 11:06
Location: Beograd

Post Napisano: 10 Oct 2015, 09:59


Evo ako nekome zatreba kako da se na Slackware-u instalira Viber.
Pošto koristim Slackware 14.1 64 bit (trenutnu bez multiliba) ovo važi samo za 64-bitnu verziju.
Verujem da mnogi koji imaju Android telefone koriste Viber i da će im mogućnost da
mogu da ga koriste i sa desktop računara značiti.
Nisam Viber instalirao na 32-bitnom sistemu,pa ako je neko voljan da proba neka dopiše
da li radi i tu. Inače zvanično postoji samo 64 bitna verzija.
Samo pri prvom prijavljivanju Viber vam mora biti upaljen na telefonu da bi ste dobili kod
koji ćete posle ukucati u programu.
Preuzmite program sa adrese, ali preuzmite rpm file (postoji deb i rpm)
https://www.viber.com/en/products/linux" onclick="window.open(this.href);return false;
Zatim iz terminala se prebacite u folder gde je snimljen (npr. Downloads)
i kucate sledeću komandu:

Code: Select all

rpm2tgz viber.rpm
sačekate da završi i samo posle instalirate sa
pkgtool

i to je to :beer:



Administrator
Administrator
offline
User avatar

Posts: 2444
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 19 Oct 2015, 20:33


Viber slackbuilds skripta se nalazi na http://slackbuilds.org/" onclick="window.open(this.href);return false; i može se iskoristiti skripta za pravljenje Slackware paketa, automatski putem sbotools-a ili sbopkg alata a može i ručno, preuzimanjem skripte sa ovog linka. Na istoj adresi se nalazi i viber.deb neophodan za upotrebu skripte.

Postupak instalacije radi i na -current verziji Slackware-a.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Poznata ličnost
Poznata ličnost
offline

Posts: 106
Joined: 01 May 2012, 23:26
Location: 42,69 - 22,16

Post Napisano: 19 Feb 2017, 23:17


Zdravo.
Kao zavisnost ,za instalaciju ver. 6.5.5.1481, pominje se qt5.,tj. potrebno ga je instalirati pre vibera ?. Da li će njegova instalacija na 14.2 stable, ugroziti stabilnost sistema. (Sam izvorni fajl je težak 322 MB) ?
Stereo je dao link ka verziji 4.2.2.6. Koja je razlika i šta je preporuka instalirati ?
Pozdrav.



Administrator
Administrator
offline
User avatar

Posts: 2444
Joined: 01 Apr 2012, 13:50
Location: Mlečni put

Post Napisano: 21 Feb 2017, 18:04


Kod mene je Viber 6.5.5 i imam qt5 paket od AlienBob-a i nigde nisam primetio neku nestabilnost. E sad, već neko vreme ne vozim Plasma-u i KDE ali i dok sam imao ta okruženja nisam primetio da je bilo šta bilo nestabilno dodavanjem qt5 kao međuzavisnosti.
Use the source, Luke
SSZ irc kanal
Spread the Word, “CHOOSE SLACK! and Don’t look back.”



Poznata ličnost
Poznata ličnost
offline

Posts: 106
Joined: 01 May 2012, 23:26
Location: 42,69 - 22,16

Post Napisano: 26 Feb 2017, 22:20


Ok. kompajlirao sam qt5 (proces je trajao na mom laptopu 15-ak sati) i Viber 6.5.5. Sve radi ok u XFCE-u. Pretpostavljam da je tako i u KDE-u.
Pozdrav



Administrator
Administrator
offline
User avatar

Posts: 3933
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 27 Feb 2017, 16:16


Koliko je meni poznato, verzija Qt5 dolazi uz Viber.

Ovo se nalazi u jednom od poddirektorijuma u originalnom deb paketu za Debian/Ubuntu koji se koristi za kreiranje Slackware paketa:
-rwxr-xr-x 1 bocke users 27344 jan 16 15:49 libQt5Concurrent.so.5*
-rwxr-xr-x 1 bocke users 5561328 jan 16 15:49 libQt5Core.so.5*
-rwxr-xr-x 1 bocke users 513688 jan 16 15:49 libQt5DBus.so.5*
-rwxr-xr-x 1 bocke users 5854464 jan 16 15:49 libQt5Gui.so.5*
-rwxr-xr-x 1 bocke users 565688 jan 16 15:49 libQt5Location.so.5*
-rwxr-xr-x 1 bocke users 1103256 jan 16 15:49 libQt5Multimedia.so.5*
-rwxr-xr-x 1 bocke users 118928 jan 16 15:49 libQt5MultimediaQuick_p.so.5*
-rwxr-xr-x 1 bocke users 127392 jan 16 15:49 libQt5MultimediaWidgets.so.5*
-rwxr-xr-x 1 bocke users 1420768 jan 16 15:49 libQt5Network.so.5*
-rwxr-xr-x 1 bocke users 358752 jan 16 15:49 libQt5OpenGL.so.5*
-rwxr-xr-x 1 bocke users 257760 jan 16 15:49 libQt5Positioning.so.5*
-rwxr-xr-x 1 bocke users 450784 jan 16 15:49 libQt5PrintSupport.so.5*
-rwxr-xr-x 1 bocke users 4116056 jan 16 15:49 libQt5Qml.so.5*
-rwxr-xr-x 1 bocke users 4164272 jan 16 15:49 libQt5Quick.so.5*
-rwxr-xr-x 1 bocke users 73680 jan 16 15:49 libQt5QuickWidgets.so.5*
-rwxr-xr-x 1 bocke users 278336 jan 16 15:49 libQt5Sql.so.5*
-rwxr-xr-x 1 bocke users 346608 jan 16 15:49 libQt5Svg.so.5*
-rwxr-xr-x 1 bocke users 122632 jan 16 15:49 libQt5WebChannel.so.5*
-rwxr-xr-x 1 bocke users 305272 jan 16 15:49 libQt5WebEngine.so.5*
-rwxr-xr-x 1 bocke users 74994192 jan 16 15:49 libQt5WebEngineCore.so.5*
-rwxr-xr-x 1 bocke users 215288 jan 16 15:49 libQt5WebEngineWidgets.so.5*
-rwxr-xr-x 1 bocke users 172064 jan 16 15:49 libQt5WebSockets.so.5*
-rwxr-xr-x 1 bocke users 6759312 jan 16 15:49 libQt5Widgets.so.5*
-rwxr-xr-x 1 bocke users 1232040 jan 16 15:49 libQt5XcbQpa.so.5*
-rw-r--r-- 1 bocke users 23516256 jan 16 15:49 libicudata.so.52
-rw-r--r-- 1 bocke users 2421592 jan 16 15:49 libicui18n.so.52
-rw-r--r-- 1 bocke users 1646064 jan 16 15:49 libicuuc.so.52
-rw-r--r-- 1 bocke users 161056 jan 16 15:49 libpng12.so.0
-rwxr-xr-x 1 bocke users 242224 jan 16 15:49 libqgsttools_p.so.1*
-rwxrwxr-x 1 bocke users 75128 jan 16 15:49 libqrencode.so*
-rw-r--r-- 1 bocke users 14288 jan 16 15:49 libxcb-xinerama.so.0
To meni deluje kao Qt5 sa zavisnostima.

A prema izlazu ldd, izgleda da Viber čak i ne koristi sistemski Qt5:

Code: Select all

$ ldd Viber  | grep \/usr\/share

	libqrencode.so => /usr/share/viber/./lib/libqrencode.so (0x00007ff1b5941000)
	libQt5Sql.so.5 => /usr/share/viber/./lib/libQt5Sql.so.5 (0x00007ff1b5196000)
	libQt5Multimedia.so.5 => /usr/share/viber/./lib/libQt5Multimedia.so.5 (0x00007ff1b5087000)
	libQt5WebSockets.so.5 => /usr/share/viber/./lib/libQt5WebSockets.so.5 (0x00007ff1b505c000)
	libQt5WebEngine.so.5 => /usr/share/viber/./lib/libQt5WebEngine.so.5 (0x00007ff1b5010000)
	libQt5PrintSupport.so.5 => /usr/share/viber/./lib/libQt5PrintSupport.so.5 (0x00007ff1b4fa1000)
	libQt5DBus.so.5 => /usr/share/viber/./lib/libQt5DBus.so.5 (0x00007ff1b4f22000)
	libicui18n.so.52 => /usr/share/viber/./lib/libicui18n.so.52 (0x00007ff1b3e99000)
	libicuuc.so.52 => /usr/share/viber/./lib/libicuuc.so.52 (0x00007ff1b3b03000)
	libQt5WebEngineCore.so.5 => /usr/share/viber/./lib/libQt5WebEngineCore.so.5 (0x00007ff1af2b0000)
	libQt5Quick.so.5 => /usr/share/viber/./lib/libQt5Quick.so.5 (0x00007ff1aeeb6000)
	libQt5Qml.so.5 => /usr/share/viber/./lib/libQt5Qml.so.5 (0x00007ff1aeac6000)
	libQt5Network.so.5 => /usr/share/viber/./lib/libQt5Network.so.5 (0x00007ff1ae96a000)
	libQt5Widgets.so.5 => /usr/share/viber/./lib/libQt5Widgets.so.5 (0x00007ff1ae2f4000)
	libQt5Gui.so.5 => /usr/share/viber/./lib/libQt5Gui.so.5 (0x00007ff1add58000)
	libQt5Core.so.5 => /usr/share/viber/./lib/libQt5Core.so.5 (0x00007ff1ad80a000)
	libQt5WebChannel.so.5 => /usr/share/viber/./lib/libQt5WebChannel.so.5 (0x00007ff1ac2fe000)
	libicudata.so.52 => /usr/share/viber/./lib/libicudata.so.52 (0x00007ff1aa841000)
	libQt5Positioning.so.5 => /usr/share/viber/./lib/libQt5Positioning.so.5 (0x00007ff1aa801000)
	libpng12.so.0 => /usr/share/viber/./lib/libpng12.so.0 (0x00007ff1a9411000)
Primer izlaza ldd za aplikaciju koja koristi sistemski Qt5:

Code: Select all

$ ldd /usr/bin/cutemarked  | grep libQt5

	libQt5WebKitWidgets.so.5 => /usr/lib64/libQt5WebKitWidgets.so.5 (0x00007f9344f88000)
	libQt5PrintSupport.so.5 => /usr/lib64/libQt5PrintSupport.so.5 (0x00007f9344d19000)
	libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007f93444b9000)
	libQt5WebKit.so.5 => /usr/lib64/libQt5WebKit.so.5 (0x00007f9341eb8000)
	libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007f9341744000)
	libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5 (0x00007f93413f5000)
	libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007f9340d3a000)
	libQt5Sensors.so.5 => /usr/lib64/libQt5Sensors.so.5 (0x00007f933ae13000)
	libQt5Positioning.so.5 => /usr/lib64/libQt5Positioning.so.5 (0x00007f933abd6000)
	libQt5OpenGL.so.5 => /usr/lib64/libQt5OpenGL.so.5 (0x00007f933a97f000)
	libQt5Sql.so.5 => /usr/lib64/libQt5Sql.so.5 (0x00007f933a73f000)
	libQt5Quick.so.5 => /usr/lib64/libQt5Quick.so.5 (0x00007f9339478000)
	libQt5Qml.so.5 => /usr/lib64/libQt5Qml.so.5 (0x00007f9338e61000)
	libQt5WebChannel.so.5 => /usr/lib64/libQt5WebChannel.so.5 (0x00007f9338c42000)


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest