xf86-video-sisimedia

Kreiranje Slackware paketa

Moderator: Urednik


Administrator
Administrator
offline
User avatar

Posts: 4130
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 11 Jan 2014, 00:49


Ok, znači bolje je ostaviti taj patch (ta ideja je bila čisto nagađanje). :) Uporno vrtim spisak patcheva i proveravam PKGBUILD, ali ne vidim da bilo šta nedostaje. Pa rekoh da pitam da nemaš možda /etc/X11/xorg.conf ili nešto u /etc/X11/xorg.conf.d/?



Administrator
Administrator
offline
User avatar

Posts: 1337
Joined: 07 Jun 2012, 18:01
Location: Najlipši grad na svitu :)

Post Napisano: 11 Jan 2014, 01:01


imam xorg.conf, a u /etc/X11/xorg.conf.d/ je prazan
edit: xorg.conf sam bio i brisao, rebootao komp u init3, kreirao novi xorg.conf i efekt isti :)
Udruga SOK - službena stranica
Spreman sam umrijeti časno, ali ako nečasno, onda ništa



Administrator
Administrator
offline
User avatar

Posts: 4130
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 11 Jan 2014, 12:51


xorg.conf ti ne treba osim ako nije potrebna neka dodatna opcija. A i za to danas preferiraju posebnu datoteku u /etc/X11/xorg.conf.d/ koja sadrži samo ta neophodna podešavanja. :)

Pogledaću još malo kad stignem. Verovatno se da uraditi nešto. U međuvremenu... Overi /var/log/Xorg.0.log koji drajver je u upotrebi. :)



Administrator
Administrator
offline
User avatar

Posts: 1337
Joined: 07 Jun 2012, 18:01
Location: Najlipši grad na svitu :)

Post Napisano: 11 Jan 2014, 14:47


instalirao opet driver, izbrisao xorg.conf i on nakon reboota diže "vesa" driver i to u 1024x768_60 Hz.
Udruga SOK - službena stranica
Spreman sam umrijeti časno, ali ako nečasno, onda ništa



Administrator
Administrator
offline
User avatar

Posts: 4130
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 12 Jan 2014, 22:01


Jesi li siguran? :) Ne diže sisimedia?

Nevezano za taj drajver, jesi li probao xf86-video-modesetting?

Edit

Šta imaš uopšte instalirano od xf86-video-* drajvera?



Administrator
Administrator
offline
User avatar

Posts: 1337
Joined: 07 Jun 2012, 18:01
Location: Najlipši grad na svitu :)

Post Napisano: 12 Jan 2014, 22:13


u /var/log/Xorg.0.log fajlu samo Vesa driver pokazuje... kako misliš da probam xf86-video-modesetting?
potencijalno zanimljiv dio fajla:

Code: Select all

[44.998] (II) VESA(0): Total Memory: 2048 64KB banks (131072kB)
[    44.998] (II) VESA(0): <default monitor>: Using default hsync range of 31.50-48.00 kHz
[    44.998] (II) VESA(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz
[    44.998] (II) VESA(0): <default monitor>: Using default maximum pixel clock of 65.00 MHz
[    44.998] (WW) VESA(0): Unable to estimate virtual size
[    44.998] (II) VESA(0): Not using built-in mode "1280x768" (no mode of this name)
[    44.998] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
[    44.998] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
[    44.998] (II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
[    44.998] (WW) VESA(0): No valid modes left. Trying less strict filter...
[    44.998] (II) VESA(0): <default monitor>: Using hsync range of 31.50-48.00 kHz
[    44.998] (II) VESA(0): <default monitor>: Using vrefresh range of 50.00-70.00 Hz
[    44.998] (II) VESA(0): <default monitor>: Using maximum pixel clock of 65.00 MHz
[    44.998] (WW) VESA(0): Unable to estimate virtual size
[    44.998] (II) VESA(0): Not using built-in mode "1280x768" (hsync out of range)
[    44.998] (--) VESA(0): Virtual size is 1024x768 (pitch 1024)
[    44.998] (**) VESA(0): *Built-in mode "1024x768"
[    44.998] (**) VESA(0): *Built-in mode "800x600"
[    44.998] (**) VESA(0): *Built-in mode "640x480"
[    44.998] (==) VESA(0): DPI set to (96, 96)
[    44.998] (II) VESA(0): Attempting to use 60Hz refresh for mode "1024x768" (118)
[    44.998] (II) VESA(0): Attempting to use 60Hz refresh for mode "800x600" (115)
[    44.998] (II) VESA(0): Attempting to use 60Hz refresh for mode "640x480" (112)
[    44.998] (**) VESA(0): Using "Shadow Framebuffer"
[    44.998] (II) Loading sub module "shadow"
[    44.998] (II) LoadModule: "shadow"
[    44.999] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    45.005] (II) Module shadow: vendor="X.Org Foundation"
[    45.005] 	compiled for 1.14.3, module version = 1.1.0
[    45.006] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    45.006] (II) Loading sub module "fb"
[    45.006] (II) LoadModule: "fb"
[    45.006] (II) Loading /usr/lib/xorg/modules/libfb.so
[    45.028] (II) Module fb: vendor="X.Org Foundation"
[    45.028] 	compiled for 1.14.3, module version = 1.0.0
[    45.028] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    45.029] (II) UnloadModule: "sis"
[    45.029] (II) Unloading sis
[    45.029] (==) Depth 24 pixmap format is 32 bpp
[    45.029] (II) Loading sub module "int10"
[    45.029] (II) LoadModule: "int10"
[    45.030] (II) Loading /usr/lib/xorg/modules/libint10.so
[    45.030] (II) Module int10: vendor="X.Org Foundation"
[    45.030] 	compiled for 1.14.3, module version = 1.0.0
[    45.030] 	ABI class: X.Org Video Driver, version 14.1
[    45.030] (II) VESA(0): initializing int10
[    45.036] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    45.038] (II) VESA(0): VESA BIOS detected
[    45.038] (II) VESA(0): VESA VBE Version 3.0
[    45.038] (II) VESA(0): VESA VBE Total Mem: 131072 kB
[    45.038] (II) VESA(0): VESA VBE OEM: SiS
[    45.038] (II) VESA(0): VESA VBE OEM Software Rev: 1.0
[    45.038] (II) VESA(0): VESA VBE OEM Vendor: Silicon Integrated Systems Corp.
[    45.038] (II) VESA(0): VESA VBE OEM Product: 6330
[    45.038] (II) VESA(0): VESA VBE OEM Product Rev: 3.72.14A
[    45.041] (II) VESA(0): virtual address = 0xaf048000,
	physical address = 0xc0000000, size = 134217728
[    45.055] (II) VESA(0): Setting up VESA Mode 0x118 (1024x768)
[    45.524] (==) VESA(0): Default visual is TrueColor
[    45.661] (==) VESA(0): Backing store disabled
[    45.662] (==) VESA(0): DPMS enabled
[    45.663] (==) RandR enabled
[    45.707] (II) AIGLX: Screen 0 is not DRI2 capable
[    45.707] (II) AIGLX: Screen 0 is not DRI capable
[    45.974] (II) AIGLX: Loaded and initialized swrast
[    45.974] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[    46.494] (II) config/udev: Adding input device Power Button (/dev/input/event5)
xf86-video-siliconmotion
xf86-video-sis
xf86-video-sisimedia
xf86-video-sisusb
xf86-video-vesa
Udruga SOK - službena stranica
Spreman sam umrijeti časno, ali ako nečasno, onda ništa



Administrator
Administrator
offline
User avatar

Posts: 4130
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 12 Jan 2014, 22:53


Ako ti se da eksperimentisati, ja bih da probamo nešto. :)

Code: Select all

init 3
slackpkg remove xf86-video-*
slackpkg install xf86-video-modsetting
Ako nisi raspoložen za igranje, obriši sve osim sisimedia drajvera. U /etc/inittab prebaci podrazumevani init level na 3 (za slučaj da X ne bude hteo da se diže). Probaj da pokrećeš X sa startx. Ako to već radiš tako, onda taj deo slobodno izignoriši. :)



Administrator
Administrator
offline
User avatar

Posts: 1337
Joined: 07 Jun 2012, 18:01
Location: Najlipši grad na svitu :)

Post Napisano: 12 Jan 2014, 23:04


ne diže X ni sa modesetting ni sa sisimedia. čudno, sa sisimedia diže X jedino ako ga natjeram u xorg.confu da koristi taj driver...
da se razumijemo, nakon predloženih koraka nisam pokretao xorgsetup ;)
Udruga SOK - službena stranica
Spreman sam umrijeti časno, ali ako nečasno, onda ništa



Administrator
Administrator
offline
User avatar

Posts: 4130
Joined: 04 Feb 2011, 20:32
Location: Beograd
Contact:

Post Napisano: 14 Jan 2014, 18:25


Aha, ok. Baciću pogled da li ima nešto na netu u vezi toga kada stignem. :)

Ako ti treba brzo rešenje, moj predlog je da se vrneš na 14.0. Ako ti je to problem, potencijalno rešenje je i downgrade Xorg. Ali to bi moglo biti veliko cimanje.

Verujem da postoji rešenje (pa uostalom ako Arči, mora i da Slakuje :)), ali mora da se "lista net". A trenutno teško odvajam vreme za to. :)



Administrator
Administrator
offline
User avatar

Posts: 1337
Joined: 07 Jun 2012, 18:01
Location: Najlipši grad na svitu :)

Post Napisano: 14 Jan 2014, 20:54


ma nema potrebe za vraćanjem na 14, neka ostane zasad ovako. Ni ja trenutno nisam pri višku vremena pa ću ovo ostaviti za kasnije. Puno ti hvala na svom uloženom trudu :beer:
Udruga SOK - službena stranica
Spreman sam umrijeti časno, ali ako nečasno, onda ništa


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest